Results 1 to 2 of 2

Thread: 97 vr4 not boosting well when warmed up

  1. #1

    Offline
     
    Name
    Elliot
    Join Date
    Oct 2018
    Last Online
    10-10-2018
    Posts
    1
    Country
    New Zealand
    Car
    97vr4 Galant
     

    97 vr4 not boosting well when warmed up

    my 97 vr4 just brought it . it boosts well when cold but when its warm I go to boost and it boosts but then feels like the power goes away a bit only running 7psi . do you think it could be the intercooler leaking somewhere ?

  2. #2
    Nick Mann's Avatar

    Offline
     
    Name
    Nick
    Join Date
    Sep 2003
    Last Online
    21-09-2020
    Membership ID
    17
    Posts
    24,572
    Country
    United Kingdom
    Location
    Redditch
    Car
    Legnum type-S
    My Garage
    Visit
     
    7psi is about right iirc.

    You could have a boost leak somewhere. In fact most VR4s that vet properly checked have boost leaks!

Similar Threads

  1. Over Boosting?
    By Tanga in forum NZ Chat
    Replies: 5
    Last Post: 06-09-2013, 06:22 AM
  2. MBC boosting too much
    By kNuTz in forum Boost Control
    Replies: 4
    Last Post: 02-07-2011, 12:14 PM
  3. boosting ar 0.5 insread of a bar
    By VR4Kaos in forum General / Questions
    Replies: 33
    Last Post: 13-07-2010, 11:17 AM
  4. i think my car boosting too low. HELP
    By Biggie_Smalls in forum General / Questions
    Replies: 15
    Last Post: 12-02-2009, 03:19 PM
  5. Boosting too much....
    By Axeboy in forum Boost Control
    Replies: 4
    Last Post: 08-08-2006, 04:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •