Results 1 to 3 of 3

Thread: ATF issues when warm

  1. #1

    Offline
     
    Name
    Ed
    Join Date
    Apr 2022
    Last Online
    15-02-2024
    Posts
    1
    Country
    Japan
    Car
    Legnum VR4
     

    Question ATF issues when warm

    Hi,

    my ~70k kms PFL Legnum AT has started showing some concerning transmission behavior. Seems to be getting worse and collecting more issues as ambient temps increase toward summer.
    All three of these things seem to only happen after warming up to a normal operating temp. Everything works fine when cold:

    Symptom 1: Hard 1-2 shifts after driving awhile (at least 15-20 minutes) This was the only issue for awhile, a few months.
    Symptom 2: Automatic upshifts from 2-3 hang sometimes. As in, it stays in gear when it should be upshifting based on speed and load. I believe when this happened, 2nd gear LED is maintained on cluster as well. When this occurs, switching to manual mode and upshifting works fine.
    Symptom 3: Noticeable slipping of torque from a start in first gear. Not completely debilitating, but to the point where I.


    I am not sure the background of the fluid or how old it is, to be honest I assumed it was changed when the engine was swapped before I got the car, but I'm realizing now if it isn't necessary to change fluid on a short block swap, they may not have done so.
    Any of these issues ring a bell with anyone?

    Thanks!

  2. #2
    miller's Avatar

    Offline
     
    Name
    Mike
    Join Date
    Jul 2007
    Last Online
    07-06-2024
    Posts
    9,489
    Country
    United Kingdom
    Location
    Notts & Navan
    Car
    EVO 1RS
     
    Your first port of call would be a full gearbox oil flush, not just a drain and refill but a full flush with good decent oil like Amsoil. This could take up to 14 litres of oil before it runs true clear colour IIRC. THose more knowledgable will be along to show.

    I recall my low mileage Legnum when I first bought it had a tendency to slip slightly and then gear hang before eventually changing into gear with a 'slap'

    A full flush with Amsoil sorted this out and went on to survive to this day!
    Still here somewhere........

  3. #3
    Confused's Avatar

    Offline
     
    Name
    Garry
    Join Date
    Apr 2005
    Last Online
    10-06-2024
    Membership ID
    714
    Posts
    3,552
    Country
    United Kingdom
    Location
    Notts
    Car
    Legnum VR-4
    My Garage
    Visit
     
    All of these symptoms sounds like old or bad or incorrect fluid.

    If you are not sure of the state of the fluid, get it changed to something you know is good and correct, I would strongly recommend Amsoil ATF, and be sure to perform a full flush https://www.clubvr4.com/forum/showth...box+oil+change

Similar Threads

  1. Warm Hello from Saudi Arabia
    By Eyad311 in forum Newbies Area
    Replies: 8
    Last Post: 04-04-2012, 09:41 PM
  2. Warm air box...
    By bradc in forum Engine
    Replies: 13
    Last Post: 20-05-2008, 09:10 AM
  3. Warm Spec
    By gee118 in forum General / Questions
    Replies: 20
    Last Post: 14-02-2008, 01:34 PM
  4. A bit warm on tickover ??
    By SGHOM in forum Random Pictures / Videos / Jokes
    Replies: 1
    Last Post: 24-11-2007, 09:11 AM
  5. Keeping Under 3K rpm until Warm
    By KiwiTT in forum General / Questions
    Replies: 15
    Last Post: 25-02-2004, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •